博客从 bo-blog 转移到WordPress中,内容有些丢失,后续正在维修中

最近很忙,很久么有更新博客了

2016年5月27日 没有评论

感觉是越来越忙的样子,一晃时间就过去了,过去的很快,也没有更新啥博客了。一看还是几个月前的。

最近一周忙着处理公司的服务器网络,连续加了2个晚上的班了,总算有个结果吧,先这样了。

各种事情,总是感觉很忙的样子,就是闲了下来,也不知道该做些什么? 迷茫!

分类: 生活杂谈 标签:

淘宝购买了一个富士康的atom d522 迷你主机做timemachine

2016年2月20日 没有评论

经历了一次的硬盘突然崩溃后, 越发的觉得需要一个备份系统了. 经过考虑很久, 入手了如下的设备作为 macosx 的备份系统.

价格 328. 不包括硬盘内存.

图片如下

TB23nKagpXXXXamXXXXXXXXXXXX_!!1824945131

系统安装的是 debian 8 64. 硬盘是日立500G笔记本硬盘, 内存是升级换下来的ddr3 1066的笔记本内存. 装上去以后, 用起来刚好.

配置好系统以后, 用osx的time machine 的效果如下

屏幕快照 2016-02-20 21.52.21

分类: Linux服务器 标签:

2016了, 该更新下博客了

2016年2月20日 1 条评论

2015 过的很快, 感觉特别的快. 在2015 这一年内, 我经历了2件大事.

1. 我的女儿钉铛出生, 我做爸爸了.
2. 我的奶奶永远的离开我们了, 奶奶在最后的生命的几年内, 活的很可怜. 我觉得很痛心. 身在农村, 生在农村, 死在农村. 一辈子都没有出过村. 心中千言万语, 历历在目.

2015 刚好过了30 了. 也就是俗话说的30而立. 可是我真的立了吗? 也许也只有我自己知道.

随着年纪的增大, 也不怎么写博客了. 总觉得没时间, 可是时间到底去哪了, 我也不清楚.

谨以此简单的记录下我的2015吧. 希望 2016 平平安安, 父母身体健康. 千言万语, 此处省略若干 ….

分类: 生活杂谈 标签:

router os 更新 he.net 免费动态dns脚本

2016年1月3日 没有评论

各种免费的ddns, 用了都是浮云, 最后的尝试, 还是 he.net 的靠谱, 具体参考 dns.he.net. 免费的DNS,好用.

ros 动态更新脚本如下.

# Define user variables
# Please NOTE that your username and password will be sent cleartext across the internet!
:local eduser "动态域名"
:local edpass "密钥"
:local eddomain "动态域名" 
:local edinterface "pppoe-out1"

# Change this global variable if you want more than 1 script
:global edlastip1
:local str
:local edip
:local ip

:if ([ :typeof $edlastip1 ] = nil ) do={ :global edlastip1 "0" }

:local edip [ /ip address get [/ip address find interface=$edinterface ] address ]

:if ([ :typeof $edip ] = nil ) do={
   :log info ("EveryDNS: No ip address on $edinterface .")
} else={

# strip off netmask correctly (MRz)
   :for i from=( [:len $edip] - 1) to=0 do={ 
      :if ( [:pick $edip $i] = "/") do={ 
       :set edip [:pick $edip 0 $i];
      } 
   }

  :if ($edip != $edlastip1) do={

    :log info ("EveryDNS: $eddomain -> $edip")
# use url directly and mode http (MRz)
    :local str "/nic/update?hostname=$eddomain&myip=$edip"
    /tool fetch url="http://dyn.dns.he.net/$str" mode=http user=$eduser password=$edpass \
       dst-path=("/EveryDNS.".$eddomain)
    :delay 1 

# output any error messages received from file
    :local str [/file find name="EveryDNS.$eddomain"];
    :log info [/file get $str contents];
    /file remove $str
    :global edlastip1 $edip

  } 

}
# Coded by Paxy

分类: 技术探讨, 脚本编程 标签:

centos 6 安装 kvm 总结

2015年12月25日 没有评论

最近比较彻底的在centos6 上面安装了kvm. 基本上能到生产环境的目标. 主要用到了如下几点

1. 安装 kvm 软件
2. 安装 guest os. 为 centos6 64, 并设置为开机自动启动
3. 设置远程 vnc 连接, 并设置密码
4. 设置 guest os 网络, 默认为 nat 方式.
5. 为 guest os 设置端口映射, 就是把 host os 的外网端口映射到 guest os 上面.
6. 其他, 比如拷贝 vm. 一个命令就行了.

折腾完上面的步骤以后, 基本上算是OK了. 本人最近比较健忘, 特把相关的命令和脚本记录一下.

1. 安装部分, 安装kvm基本上没有什么技术含量. 就是要设置 host os 的 eth0 网卡桥接到 br0 上面. 相关的脚本参考 wiki, 我测试过, 很好用.
参考 https://wiki.centos.org/HowTos/KVM

2. 安装 guest os
相关的脚本如下, 具体含义就不解释了. 本人测试过, 是可以工作的. 准备好 ISO 文件和相关的目录即可. 不多做解释了.
说明下: network=default 表示用 default 的网络配置文件. 这个文件的位置在 /etc/libvirt/qemu/networks/ , 主要是定义了 DHCP 的相关选项. 一般不需要修改什么即可. 默认的.


virt-install --name=test --ram 512 --vcpus=1 \
--disk /data/vms/test.qcow2,size=20,bus=virtio,cache=writeback \
--cdrom /data/CentOS-6.7-x86_64-minimal.iso \
--graphics vnc,listen=0.0.0.0,port=5988,password=123456 \
--network network=default, --force --autostart

3. 然后用 vnc 连接, 输入 host os 的 端口 5988, 密码 123456. 安装完成即可.

4. 设置 guest os 的网络. guest os 安装完毕以后. 需要 nat 模式上网. 默认模式下 guest os 获取的ip地址为 192.168.122.X/24 的. 如果需要修改, 修改 /etc/libvirt/qemu/networks/default.xml 文件. 修改以后, 需要运行. 修改 guest os 的配置文件以后, 同样需要运行这个命令.

virsh define /etc/libvirt/qemu/networks/default.xml

5. 设置 guest os 的nat. 这个地方有个坑. 我搜索了各种方案, 都是不好用的. 后来找到 GitHub 上面的一个脚本. 很好用. 地址 https://github.com/saschpe/libvirt-hook-qemu
下载这个脚本. make install 就好了. 注意. 这个脚本只能运行在 python2.7 上面. 默认的centos6 的python是2.6 的. 这个地方又是一个坑. 所以需要安装 python 2.7. 好吧, 安装 python 2.7 的方法, 参考如下连接. https://segmentfault.com/a/1190000000654227 我就不额外解释了.

GitHub 的那个脚本的使用方法: 下载以后, make install. 然后修改 /etc/libvirt/hooks/qemu 这个文件. 把第一行修改如下 #!/usr/local/bin/python2.7. 表示用 python2.7 来运行. 否则报错.

进入 /etc/libvirt/hooks. 里面有个文件 qemu.json , 格式如下

{
    "test": {      // guest os 的名字
        "interface": "virbr0",            // 桥接的网卡
        "private_ip": "192.168.122.11",   /* guest os ip地址 */
        "port_map": {     
            "tcp": [[11022, 22], [80, 80]]  // 映射的端口
        }
    },
    "c6": {
        "interface": "virbr0",
        "private_ip": "192.168.122.12",
        "port_map": {
            "tcp": [[80, 80],
                    [443, 443], [12022, 22]]
        }
    }
}

上面的文件, 自己看着修改吧. 记得修改前, 先关掉 guest os. 然后修改. 再启动 guest os. 端口映射就自动生效了, 不用搞什么 iptables 命令了.

6. 拷贝guest os. 这个就是体现虚拟化的好处了. 一个命令, 就可以克隆好多个新的 guest os了. 如下命令, 表示把 test 这个 guest os ,克隆一份为 radius. 同时设定硬盘路径为 /data/vms/radius-20g.qcow2

  virt-clone -o test -n radius --file /data/vms/radius-20g.qcow2  

7. guest 开机, 关机命令

开机: virsh start guest_os_name
关机: virsh shutdown|destroy guest_os_name

8. 设置 guest os 开机自动启动. 这个很容易. 做一个配置文件的 xml 软连接即可. 比如: ln -s /etc/libvirt/qemu/test.xml /etc/libvirt/qemu/autostart/test.xml

参考文章: https://segmentfault.com/a/1190000000644069

分类: Linux服务器, 虚拟化 标签: ,

艹尼玛的VMBOX.CO

2015年12月4日 没有评论

日他大爷的, 收了钱, 结果把我的vps给停掉了.工单几天不回.估计应该是跑路了. 这种小vps商家真是不靠谱啊,结果我的所有数据只能恢复到一年前的了!妈的,想着就气人

分类: 未分类 标签:

router os 的定时重启,定时重新拨号的脚本

2015年1月10日 没有评论

长宽用户,很奇怪,拨号太久,网络会变得很卡,重新拨一下号就好了,很神奇.所以就网上找了下自动重启和拨号的脚本.

# 这个是每两天重启一次路由器 49h

/system scheduler add name=reboot interval=48h start-time=06:00:00 on-event={/system
reboot} disabled=no 

# 每天重新拨号一次,这个是先禁用

/system scheduler add name="NolinePPP" on-event="/inter pppoe-client set [/inter pppoe-client find name=\"pppoe-out1\"] disabled=yes" start-date=Jan/01/1970 start-time="07:30:00" interval="1d 00:00:00" comment="NolinePPP" disabled=no 

# 每天重新拨号一次,这个是启用

/system scheduler add name="linePPP" on-event="/inter pppoe-client set [/inter pppoe-client find name=\"pppoe-out1\"] disabled=no" start-date=Jan/01/1970 start-time="07:30:35" interval="1d 00:00:00" comment="linePPP" disabled=no 
分类: Linux服务器, 技术探讨 标签:

uTorrent去掉左下角广告和广告条

2014年12月29日 没有评论

去掉广告条其实很简单.

打开uTorrent选项->设置->高级

搜索
offers.left_rail_offer_enabled (左下角广告栏)
gui.show_plus_upsell(左下角升级到高级版的提示)
offers.sponsored_torrent_offer_enabled(顶部栏广告)

把他们由true设置成false.然后重启uTorrent即可.

分类: 默认分类 标签:

centos6 安装 go 编译环境

2014年12月25日 没有评论

好多时候,需要编译go语言的程序. go 比较屌的一个功能就是编译一次,多平台运行. 这下好了.搭建好centos6 的编译环境. 编译好的代码,就可以在其他平台运行了. 方便

我们这里使用源码编译安装,直接按顺序执行下列命令就可以成功(我都是假设已经有root权限的情况下,所以执行之前请确认自己已有root权限):

yum install -y mercurial gcc-c++ gcc
mkdir /usr/local
cd /usr/local
hg clone -r release https://go.googlecode.com/hg/ go
cd /usr/local/go/src
chmox +x all.bash
./all.bash
mkdir /root/go
export GOROOT=/usr/local/go
export GOPATH=/root/go
export GOBIN=/usr/local/go/bin
export GOOS=linux
export PATH=.:$PATH:/usr/local/go/bin
现在应该已经可以执行go命令测试了:

[root@root]# go version
go version go1.3.3 linux/amd64
如果想要每次进入bash时都拥有go环境,则需要新建一个文件:/etc/profile.d/go.sh
并写入以下内容

export GOROOT=/usr/local/go
export GOPATH=/root/go
export GOBIN=/usr/local/go/bin
export GOOS=linux
export PATH=.:$PATH:/usr/local/go/bin
现在随时都可以执行go命令了。

xen pv/hvm xml 配置文件

2014年12月24日 没有评论

以下是 pv. 用的 pygrub. pygrub 支持在系统里面的内核.

<domain type='xen' id='-1'>
  <name>UUUUUUUU-UUUU-UUUU-UUUU-UUUUUUUUUUUU</name>
  <uuid>UUUUUUUU-UUUU-UUUU-UUUU-UUUUUUUUUUUU</uuid>
  <memory>8388608</memory>
  <currentMemory>262144</currentMemory>
  <vcpu>1</vcpu>
  <bootloader>/usr/bin/pygrub</bootloader>
  <os>
    <type>linux</type>
  </os>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <disk type='block' device='disk'>
      <driver name='phy'/>
      <source dev='/dev/vg/UUUUUUUU-UUUU-UUUU-UUUU-UUUUUUUUUUUU'/>
      <target dev='sda' bus='xen'/>
    </disk>
    <interface type='bridge'>
      <mac address='MM:MM:MM:MM:MM:MM'/>
      <source bridge='br0'/>
      <script path='/etc/xen/scripts/vif-bridge'/>
      <target dev='vif1.0'/>
    </interface>
    <console type='pty' tty='/dev/pts/1'>
      <source path='/dev/pts/1'/>
      <target port='0'/>
    </console>
  </devices>
</domain>

阅读全文…